No question at this time
DBA Top 10
1 B. Vroman 11100
2 M. Cadot 10000
3 T. Boles 6850
4 A. Kavsek 6300
5 J. Schnackenberg 5100
6 P. Wisse 2500
7 M. Hidayathullah ... 1900
8 T. P 1200
9 G. Lambregts 1100
9 . Lauri 1100
About
DBA-Village
The DBA-Village forum
Forum as RSS
as RSS feed
Site Statistics
Ever registered users48336
Total active users1567
Act. users last 24h2
Act. users last hour0
Registered user hits last week225
Registered user hits last month1036
Go up

error when logging on in Oracle Enterprise Manager console URL
Next thread: Doubt
Prev thread: how to Media Recovery the archivelog in advance at standby?

Message Score Author Date
my steps are as follows: 1. I installed oracle9i ...... Sherry Hu Aug 25, 2006, 08:02
Sorry, I meant "on a PC if installing 10g only, th...... Sherry Hu Aug 25, 2006, 08:05
Hi there I am using the following Java runtime ...... Rolland Sovarszki Aug 25, 2006, 09:16
may I ask, are you also running oracle standard ed...... Sherry Hu Aug 28, 2006, 01:26
found the problem. it's because "empatch.sql is no...... Sherry Hu Aug 28, 2006, 03:08

Follow up by mail Click here


Subject: error when logging on in Oracle Enterprise Manager console URL
Author: Sherry Hu, Australia
Date: Aug 25, 2006, 08:02, 4558 days ago
Os info: Windows XP
Oracle info: oracle10g Standard edition
Message: my steps are as follows:
1. I installed oracle9i on home ora92 first;
2. then installed oracle10g Standard edtion on a separate home (by default)with the starter database;
3. ensure that the environment is pointing to 10g home; 10g listener is up; 10g starter database is up; and the service "OracleDBConsoleorcl10g" is started;
4. when log on sys/password as sysdba in the enterprise manager console at URL http://localhost:5500/em, I got the following error:
500 Internal Server Error
java.lang.NullPointerException
at oracle.sysman.emSDK.license.LicenseManager.hasAllPacks(LicenseManager.java:467)
at oracle.sysman.emSDK.license.LicenseUtil.isLicensed(LicenseUtil.java:138)
at oracle.sysman.eml.app.Console.doGet(Console.java:246)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:740)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
at com.evermind[Oracle Application Server Containers for J2EE 10g (9.0.4.0.0)].server.http.ResourceFilterChain.doFilter(ResourceFilterChain.java:65)
at oracle.sysman.emSDK.svlt.EMRedirectFilter.doFilter(EMRedirectFilter.java:101)
at com.evermind[Oracle Application Server Containers for J2EE 10g (9.0.4.0.0)].server.http.EvermindFilterChain.doFilter(EvermindFilterChain.java:16)
at oracle.sysman.db.adm.inst.HandleRepDownFilter.doFilter(HandleRepDownFilter.java:133)
at com.evermind[Oracle Application Server Containers for J2EE 10g (9.0.4.0.0)].server.http.EvermindFilterChain.doFilter(EvermindFilterChain.java:20)
at oracle.sysman.eml.app.ContextInitFilter.doFilter(ContextInitFilter.java:269)
at com.evermind[Oracle Application Server Containers for J2EE 10g (9.0.4.0.0)].server.http.ServletRequestDispatcher.invoke(ServletRequestDispatcher.java:600)
at com.evermind[Oracle Application Server Containers for J2EE 10g (9.0.4.0.0)].server.http.ServletRequestDispatcher.forwardInternal(ServletRequestDispatcher.java:317)
at com.evermind[Oracle Application Server Containers for J2EE 10g (9.0.4.0.0)].server.http.HttpRequestHandler.processRequest(HttpRequestHandler.java:790)
at com.evermind[Oracle Application Server Containers for J2EE 10g (9.0.4.0.0)].server.http.HttpRequestHandler.run(HttpRequestHandler.java:270)
at com.evermind[Oracle Application Server Containers for J2EE 10g (9.0.4.0.0)].server.http.HttpRequestHandler.run(HttpRequestHandler.java:112)
at com.evermind[Oracle Application Server Containers for J2EE 10g (9.0.4.0.0)].util.ReleasableResourcePooledExecutor$MyWorker.run(ReleasableResourcePooledExecutor.java:192)
at java.lang.Thread.run(Thread.java:534)

DOES anybody here know why? and what should I do?

on a PC if installing 9i only, there won't be problem. I know 9i use earlier verion of java runtime from the installer. if the problem is this, how can I get 10g to run on the java Runtime with its installation?

Thanks,

Sherry
Goto: Reply - Top of page 
If you think this item violates copyrights, please click here

Subject: Re: error when logging on in Oracle Enterprise Manager console URL
Author: Sherry Hu, Australia
Date: Aug 25, 2006, 08:05, 4558 days ago
Message: Sorry, I meant "on a PC if installing 10g only, there won't be problem"

Sherry
Your rating?: This reply is Good Excellent
Goto: Reply - Top of page 
If you think this item violates copyrights, please click here

Subject: Re: error when logging on in Oracle Enterprise Manager console URL
Author: Rolland Sovarszki, Germany
Date: Aug 25, 2006, 09:16, 4558 days ago
Message: Hi there

I am using the following Java runtime environment:

J2SE Runtime Environment 5.0 Update 1
Version: 1.5.0.10

And it works fine.

c.u.
Your rating?: This reply is Good Excellent
Goto: Reply - Top of page 
If you think this item violates copyrights, please click here

Subject: Re: error when logging on in Oracle Enterprise Manager console URL
Author: Sherry Hu, Australia
Date: Aug 28, 2006, 01:26, 4555 days ago
Message: may I ask, are you also running oracle standard edtion? and have two oracle homes (with two versions)on your PC?

I checked my PC control panel, the java runtime version is :
JRE 1.5.0_05 C:\Program Files\Java\jre1.5.0_05

in oracle10g home, the java runtime version is
C:\oracle\product\10.1.0\Db_1\jre\1.4.2

when I start oracle enterprise manager console at url:
http://localhost:5500/em, the login page is presented, but when logging in, the error comes.

did anybody have the same problem?


Thanks,

Sherry
Your rating?: This reply is Good Excellent
Goto: Reply - Top of page 
If you think this item violates copyrights, please click here

Subject: Re: error when logging on in Oracle Enterprise Manager console URL
Author: Sherry Hu, Australia
Date: Aug 28, 2006, 03:08, 4555 days ago
Message: found the problem. it's because "empatch.sql is not executed as part of the patch installation. Various reasons can prevent the script from running." (according to Metalink).

solution:
stop dbconsole; log in as sysman; run empatch.sql; start dbconsole. then it is fine now.

Sherry
Your rating?: This reply is Good Excellent
Goto: Reply - Top of page 
If you think this item violates copyrights, please click here