No question at this time
DBA Top 10
1 B. Vroman 15700
2 M. Cadot 10200
3 T. Boles 8350
4 J. Schnackenberg 8300
5 A. Kavsek 7800
6 M. Hidayathullah ... 2500
7 P. Wisse 1200
8 G. Lambregts 1100
9 T. P 1000
10 B. Derous 500
10 R. Pattyn 500
About
DBA-Village
The DBA-Village forum
Forum as RSS
as RSS feed
Site Statistics
Ever registered users48277
Total active users1612
Act. users last 24h4
Act. users last hour0
Registered user hits last week185
Registered user hits last month836
Go up

Opatch failure
Next thread: DEVELOPER 6i
Prev thread: shared server

Message Score Author Date
I Installed oracle 9.2.0.4 in redhat AS 4. After t...... om prakash Dec 26, 2006, 10:50
Check if the JRE is installed, and that it is vers...... Younes Naguib Dec 26, 2006, 17:22
You need to have JRE 1.4 or above version for Opat...... girish hirde Dec 26, 2006, 19:27
The following are some details about the environme...... om prakash Dec 27, 2006, 06:49
even after java jre 1.4.1 is in the path . When i...... om prakash Dec 27, 2006, 09:56
Hi, please try and check your CLASSPATH and J_H...... Alexander Lavecchia Dec 27, 2006, 10:15
you can try to pass parameter of java path in opat...... girish hirde Dec 27, 2006, 14:21

Follow up by mail Click here


Subject: Opatch failure
Author: om prakash, India
Date: Dec 26, 2006, 10:50, 4317 days ago
Os info: redhat linux AS 4
Oracle info: 9.2.0.4
Message: I Installed oracle 9.2.0.4 in redhat AS 4. After that i downloaded the OPatch utility p4898608_10201_GENERIC.zip file and unziped that in ORACLE_HOME location. After that i tried to invoke opatch utility.

#opatch -version

But i am gettion the following error.

Please make sure you are running OPatch with JRE version 1.4 or later.

OPatch failed with error code 255



can anyone help me.


regards,
omprakash
Goto: Reply - Top of page 
If you think this item violates copyrights, please click here

Subject: Re: Opatch failure
Author: Younes Naguib, Canada
Date: Dec 26, 2006, 17:22, 4317 days ago
Message: Check if the JRE is installed, and that it is version 1.4 and up. If not, donwload the latest version from http://java.sun.com/j2se/1.4.2/download.html. If java is installed, then you may want to set the ENV variable JAVA_HOME.

Hope that helps,
Your rating?: This reply is Good Excellent
Goto: Reply - Top of page 
If you think this item violates copyrights, please click here

Subject: Re: Opatch failure
Author: girish hirde, India
Date: Dec 26, 2006, 19:27, 4317 days ago
Message: You need to have JRE 1.4 or above version for Opatch , Download it and set the path of jre, you would be able to install opatch
Your rating?: This reply is Good Excellent
Goto: Reply - Top of page 
If you think this item violates copyrights, please click here

Subject: Re: Opatch failure
Author: om prakash, India
Date: Dec 27, 2006, 06:49, 4316 days ago
Message: The following are some details about the environment of the system.


1.Environment variable settings:
--------------------------------
ORACLE_HOME=/oracle/product/9.2.0
ORACLE_SID=test
PATH=$PATH:$ORACLE_HOME/bin:$ORACLE_HOME/jdk/bin:$ORACLE_HOME/OPatch
LD_ASSUME_KERNEL=2.4.19
LD_LIBRARY_PATH=$ORACLE_HOME/lib:/lib:/usr/lib
LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib

2.oracle_home,java location:
----------------------------
oracle_home=/oracle/product/9.2.0
java location is under oracle_home

3.java version:
---------------
[oracle@test ~]$ java -version
java version "1.4.2"
gcj (GCC) 3.4.3 20041212 (Red Hat 3.4.3-9.EL4)
Copyright (C) 2004 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.


4.Opatch failure details:
-------------------------

[oracle@test ~]$ opatch -version

Please make sure you are running OPatch with JRE version 1.4 or later.

OPatch failed with error code 255



------------


regards,
omprakash
Your rating?: This reply is Good Excellent
Goto: Reply - Top of page 
If you think this item violates copyrights, please click here

Subject: Re: Opatch failure
Author: om prakash, India
Date: Dec 27, 2006, 09:56, 4316 days ago
Message: even after java jre 1.4.1 is in the path .
When i invoke opatch . its getting failed can any help me to resolve this issue.
Your rating?: This reply is Good Excellent
Goto: Reply - Top of page 
If you think this item violates copyrights, please click here

Subject: Re: Opatch failure
Author: Alexander Lavecchia, Germany
Date: Dec 27, 2006, 10:15, 4316 days ago
Message: Hi,

please try and check your CLASSPATH and J_HOME or JAVA_HOME.

Kind Regards

Alex
Your rating?: This reply is Good Excellent
Goto: Reply - Top of page 
If you think this item violates copyrights, please click here

Subject: Re: Opatch failure
Author: girish hirde, India
Date: Dec 27, 2006, 14:21, 4316 days ago
Message: you can try to pass parameter of java path in opatch command.



Your rating?: This reply is Good Excellent
Goto: Reply - Top of page 
If you think this item violates copyrights, please click here